[Nikto-discuss] Nikto not finding plugins

Subscriptions subs at qcontinuum.plus.com
Thu May 10 06:23:16 CDT 2012

I'm having trouble running Nikto on one of my servers. Its a Windows 
2008 machine. and I'm running Nikto 2.1.4.

I have Nikto installed in C:\Scripts\Nikto and if I run if from that 
directory it works fine. However, if I run it from anywhere else it 
fails with:

c:\Temp>perl c:\scripts\nikto\nikto.pl
Can't locate plugins/nikto_core.plugin in @INC (@INC contains: 
C:/strawberry/perl/site/lib C:/strawberry/perl/vendor/lib 
C:/strawberry/perl/lib .) at c:\scripts\nikto\nikto.pl line 85.

In the nikto.pl I have:

$VARIABLES{'configfile'} = "C:/Scripts/Nikto/nikto.conf";

In the config file I have also added:


This worked fine on my Vista laptop and allowed me to run Nikto from 
anywhere, but does not appear to work on Windows 2008 server.
I have also tried running perl with an -IC:/Scripts/Nikto like this:

perl -IC:/Scripts/Nikto c:/scripts/nikto/nikto.pl -F csv -o - -vhost 
localhost -timeout 5 -host -port 8834 -ssl

But this time I get:

+ ERROR: Can't find/read required file 
Time::HiRes::ualarm(): unimplemented in this 
platform at (eval 8) line 1
BEGIN failed--compilation aborted at (eval 
8) line 2.
...propagated at C:/Scripts/Nikto/plugins/nikto_core.plugin 
line 1071.

The files are there and, as I said, it works OK when I cd to the Nikto 
directory first.

Can anyone she any light on this?

More information about the Nikto-discuss mailing list