[Nikto-discuss] Nikto in Nessus

Frank Breedijk FBreedijk at schubergphilis.com
Wed Mar 12 13:26:18 UTC 2008


That would work if I was running on i386 unfortunately I am running on amd64 for which nessus-bin is not available. But, I have also tested using nessus3 on CentOS (RedHat EL recompile) and I did not have an active nikto plugin there either even though the nikto.nasl wrapper was available.


Frank Breedijk, CISSP - Security Engineer
fbreedijk at schubergphilis.com - www.schubergphilis.com

-----Original Message-----
From: nikto-discuss-bounces at attrition.org [mailto:nikto-discuss-bounces at attrition.org] On Behalf Of Tony
Sent: 12 March 2008 13:29
To: nikto-discuss at attrition.org
Subject: Re: [Nikto-discuss] Nikto in Nessus

On Wed, Mar 12, 2008 at 4:43 AM, Frank Breedijk
<FBreedijk at schubergphilis.com> wrote:
> YanYan,
>  I noticed the same thing and it appears to be an issue in the nikto plugin (14260) at least on nessus 2.2.10.
>  This is the message I set to nessus bug-report.
>  -----Original Message-----
>  From: Frank Breedijk
>  Sent: 27 February 2008 12:29
>  To: 'bug-reports at nessus.org'
>  Subject: Nikto.nasl not loaded in 2.2.10
>  This is the error message I am getting:
>  Loading the plugins... 19890 (out of 20581)nessus-libraries/libnessus/store.c: /usr/lib64/nessus/plugins/nikto.nasl has a too long preference-name (69)
>  nikto.nasl failed to load
>  All plugins loaded
>  Killed
>  I use nessus 2.2.10 on gentoo.

On gentoo you need to use the latest version of nessus-bin. I had to
copy the ebuild from portage to a PORTDIR_OVERLAY
(/usr/local/portage/net-analyzer/nessus-bin/) and rename it to the
current version available from tenables website. You have to prefetch
the suse Nessus-3.0.6-suse10.0.i586.rpm and put it in the
/usr/portage/distfiles. Then it should build fine and be able to use
the latest version of nikto.
Nikto-discuss mailing list
Nikto-discuss at attrition.org

More information about the Nikto-discuss mailing list