[Nikto-discuss] Error messages when running the nikto

Sullo csullo at gmail.com
Tue Sep 7 07:52:44 CDT 2010

2010/9/7 WuJonnie <jonnie_wu at hotmail.com>:
> I just installed the Nikto by referring to an article, and no matter which
> version nikto I tried, always returns me the same error message.
> c:\Program Files\nikto-2.1.3>perl nikto.pl -h www.abc.com
> Can't locate nikto.pl/plugins/nikto_core.plugin in @INC (@INC contains:
> C:/Perl/site/lib C:/Perl/lib .) at nikto.pl line 89.

Try editing nikto.pl and changing this line to point to your nikto.conf file:
$NIKTO{'configfile'}  = "/etc/nikto.conf";    ### Change this line if
it's having trouble finding it

I think the path would be c:\Program Files\nikto-2.1.3\nikto.conf
based on what you have in your email.

> But When I directly input like below:
> c:\Program Files\nikto-2.1.3> nikto.pl -h www.abc.com
> It will scan the site’s vulnerabilities, but anyway will have some error
> messages at the beginning.
> c:\Program Files\nikto-2.1.3>nikto.pl -h www.abc.com
> Can't locate auto/Net/SSLeay/autosplit.ix in @INC (@INC contains:
> C:/Perl/site/lib C:/Perl/lib .) at C:/Perl/lib/AutoLoader.pm line 173. at
> C:/Perl/lib/Net/SSLeay.pm line 61

Is this a new perl installation--did it work before? This looks like
an internal perl/net::ssleay module error. If this is a new install,
I'd recommend reinstalling that module and trying again. You may also
try Net::SSL to see if that works better.

Without SSL it seems to be working correctly--you just won't be able
to test encrypted resources.


http://www.cirt.net     |      http://www.osvdb.org/

More information about the Nikto-discuss mailing list