[Nikto-discuss] Nikto needs an update on thttpd?

Peter Wang wkwang at cisco.com
Mon Oct 12 17:51:48 UTC 2009

Hi Sullo,

Thank you for reply. Nikto update works now after I specified -useproxy
option. I didn't realize it needs to specify -useproxy at 1st try.

It received two file's updates as below,

-bash-3.00# ./nikto.pl -update -useproxy
+ Retrieving 'db_tests'
+ Retrieving 'db_outdated'
+ www.cirt.net message: Please submit your bugs!!

But thttpd entry didn't get updated, it still has 2.24 as current version.

-bash-3.00# grep thttpd db_outdated
"600787","thttpd/","2.2426oct2003","@RUNNING_VER appears to be outdated
(current is at least @CURRENT_VER)"


On 10/12/09 10:57 AM, "Sullo" <csullo at gmail.com> wrote:

> You're not able to resolve cirt.net, apparently, which is why the
> update is relying on the IP. The IP in the nikto.conf file is
> incorrect--it should be If you update that and try the
> -update again, it should work.
> I'm not sure that the thttpd banner has been updated, but if you still
> don't see it properly send me the current version and I'll get it
> updated.
> -Sullo
> On Mon, Oct 12, 2009 at 10:22 AM, Peter Wang <wkwang at cisco.com> wrote:
>> Hi,
>> When running Nikto 2.03 scan, Nikto reported an item of thttpd as below. It
>> looked like nikto needs an update on this.
>> Information    thttpd/2.25b29dec2003 appears to be outdated (current is at
>> least 2.2426oct2003)
>> Ran ³nikto -update ³ didn¹t get through,
>> # nikto -update
>> + ERROR (): Unable to get
>> Let me know if you have update on this issue,
>> Thanks,
>> Peter
>> _______________________________________________
>> Nikto-discuss mailing list
>> Nikto-discuss at attrition.org
>> https://attrition.org/mailman/listinfo/nikto-discuss

More information about the Nikto-discuss mailing list